Office Update Requires Sierra

The September 2018 update of Microsoft Office 365 requires macOS 10.12 Sierra or later according to Microsoft. Older versions of the operating system such as El Capitan (10.11) will still receive support for Office 365 but will not receive feature updates. Please contact MacLab to help upgrade your Mac to Sierra or newer to stay compatible. It is generally a good idea to stay within two major versions of the latest macOS for security and support. The latest macOS, 10.14 will be released shortly.

Sorry, Comments are Closed.

You'll have to take it up with the author...